Jun 12

Firefox 52 has removed all support for Netscape Plugin API (NPAPI). Plugins such as the D-Link mydlink plugin, Silverlight, Java, and Acrobat are no longer supported. mydlink portal uses mydlink plugin to access mydlink devices, and since mydlink plugin no longer works on Firefox 52, Firefox users are stuck at the plugin download page. Please note that customers using Firefox 51 are not affected. Internet Explorer and Safari still support these plugins.

Firefox users may download and install Firefox 52 ESR (Extended Support Release) which still support mydlink plugin.

 

Learn more about Firefox ESR here: https://www.mozilla.org/en-US/firefox/organizations/

 

The Firefox 52 and Firefox ESR browsers can co-exist on the same computer. We suggest keeping both browser versions on your computer.

Tags: ,

css.php